Upload to sp365 failing

  • Last Post 11 April 2022
  • Topic Is Solved
petar.georgiev posted this 28 March 2022


recently we started having issues with uploading files to sp using DN/SS, here's what the log says:

2022-03-28 1380:952 | Information | Generating output process finished.
2022-03-28 1380:968 | Detailed | Executing Connector(s)
2022-03-28 1380:983 | Detailed | Parsing connector settings
2022-03-28 1380:983 | Detailed | Parsing variables
2022-03-28 1380:999 | Detailed | Uploading document to Sharepoint server...
2022-03-28 138:43:425 | Error | Upload failed: Value does not fall within the expected range.
2022-03-28 138:43:441 | Information | Finished workflow process on the document (Documents archive)
2022-03-28 138:43:441 | Detailed | Cleaning workflow process files and folders (Documents archive)
2022-03-28 138:43:488 | Error | Workflow isn't processed successfully, reason: Connector failed, check log for details.
2022-03-28 138:43:488 | Detailed | Max number of processing attempts reached: 1, the document will be moved out of the processing queue
2022-03-28 138:43:503 | Detailed | Workflow 'Documents archive' end

Most of the time the file actually gets uploaded but without the metadata (except the file name, which is fine).

Any ideas?


Order By: Standard | Newest | Votes
luca.scarpati posted this 29 March 2022

Hi Petar,


quickly looking at your few logs lines above the issue is that one of the properties you are setting is not in the correct expected format by Sharepoint failing to set all of them.

Please check the contents of the variables you are passing into the properties and check which one produces an error, you can first output the variables to be sure about the values and try removing one by one to see which one gives that issue so we can isolate the wrong passed value.

I don't know the types of data you have but often this happens with column properties which are not simple text, such as Lists, Choices, Booleans or others where the variable value isn't in that specific format.

Specifically for Lists and Choices the value expected has a very special format which is the same one returned by the picklist connector and more precisely ID;#Value as mentioned also in the manual at https://help.scanshare.com/home/connectors/connectors-sharepoint/.

However in order not to attach logs that could have "sensitive data" in an open Forum, we always suggest contact your dealer/NOC support first, if they cannot solve it then they will contact us at our support. 


Best regards,


petar.georgiev posted this 29 March 2022

I forgot to mention - it was working fine until ~2 weeks ago. Recently we migrated the VM to a different infrastructure and I wonder could this be the issue (everything else is working). Also, it is an SP document library and the columns are set as "single line of text". We tried to install DN 5 on a different machine and import the workflow - same behavior. The variables gathered from the PC client are stored properly (we are using the same values for columns and filename), because the filename is correct, just the metadata is missing.

luigi.zurolo posted this 30 March 2022

Dear Petar,

We did some investigation to find out a reason and we found out there was a ContentType property added / changed and appearing in the Properties list inside our connector which failsafe the content type producing that error.

This property is normally a base one and computed automatically, however since when it appeared in the list it gets set as empty from the settings and the connector doesn't compute it producing the value not correct error.

This gets rolled in certain tenants, sites, libraries and / or properties, hence it may appear everywhere or not. And it also depends on new configuration where the new settings are saved with this property with an empty value part of the list and the saved settings (older settings for example won't be affected not saving it).

For now a simple solution would be to edit the connector settings and change the property name to something else than ContentType, even "xyz", "test" or anything you like and leaving its Value empty so it won't be attempted to be set. In this way the Content Type will be again computed automatically.

The behavior will be addressed in the next release in order to be handled automatically also for those new cases.

petar.georgiev posted this 31 March 2022

Where can I edit connector settings I thought these list properties are pulled from SP365?

petar.georgiev posted this 08 April 2022


luca.scarpati posted this 11 April 2022

Hi Petar,


simply click on Lost / Library properties. In the list that opens select the name of the property on the left, click on it and change it to something else also "xyz" or "test" or ... :

after which you just have to save (be careful not to reopen the list after saving otherwise you will have to repeat the same steps before saving).

Another workaround is also to set the value expected for a document which normally the connector was setting it when the property is not manually override, so you set as value(right part of the property "ContentType"): 0x0101 instead of renaming the property name. So it will stay saved with the value and it is working as well.


Have a nice week!


Best regards,


petar.georgiev posted this 11 April 2022

I've already tried this, but I guess DN 4 can't do it, I'll try with the 0x0101 value instead:

petar.georgiev posted this 11 April 2022

0x0101 value did the trick.

  • Liked by
  • luca.scarpati
luca.scarpati posted this 11 April 2022

Hi Petar,


perfect and yep inside the V4 it was not possible to change the "name" inside the table list.

However we always suggest to keep the solution updated also because version V4 will no longer receive updates, so the update of the Sharepoint connector will arrive in the next monthly release of the V5.


Have a nice week!


Best regards,