"You have exceeded the amount of memory allowed for RasterImage Allocations"

  • 316 Views
  • Last Post 08 April 2019
  • Topic Is Solved
MMSupport1 posted this 04 April 2019

Hello fellow Scansharers,

 

I got this error on working with 278 pages tiff. Is there a setting I can do to increase memory?

Or does this come under the 32/64 Bit stuff.

Thanks for the help!

Order By: Standard | Newest | Votes
luca.scarpati posted this 04 April 2019

Hi,

 

this is actually not a problem, It may just be that your server's current available memory is not able to completely process your current document.

Obviously it depends on the version and yes I do suggest you use the 64bits version which can use all the system available memory without any limitation.

 

I suggest you try to set the logs in debug mode, you will see the detail of the memory used page by page ... wink

 

Best regards,

Luca

 

 

MMSupport1 posted this 08 April 2019

2019-04-01 11:10:2399 | Debug | Getting Image for page number: 278
2019-04-01 11:10:23:415 | Debug | Current Memory usage: 182Mb, Working Set: 2542Mb
2019-04-01 11:10:23:774 | Error | You have exceeded the amount of memory allowed for RasterImage allocations.
See RasterDefaults::MemoryThreshold::MaximumGlobalRasterImageMemory.
2019-04-01 11:10:23:774 | Information | Finished workflow process on the document (Fahrzeugakte)
2019-04-01 11:10:24:946 | Debug | Unloading Imaging engine
2019-04-01 11:10:24:962 | Detailed | Cleaning workflow process files and folders (Fahrzeugakte)
2019-04-01 11:10:24:978 | Error | Workflow isn't processed successfully, reason: Connector failed, check log for details., No image to process
2019-04-01 11:10:24:978 | Detailed | Max number of processing attempts reached: 2, the document will be moved out of the processing queue

Is there a way to increase the treshold in a config file?

Or is the only way increasing usable RAM (4 gb at the moment)?

luca.scarpati posted this 08 April 2019

Hi,

 

I had asked if they are using the 64-bit or 32-bit version ... Windows for 32bit systems does not allow to exceed 2GB ...

In any case, you can change a setting in the windows Registry Editor where you can set the value of the RasterImageMemoryThreshold. About the value, this is a inverse value, means higher it is and faster cache cleaning process will be fired (at lower amount of reached threshold).

This value is combined with the possible amount of allocable memory for the process which is quite dynamic but it is almost always around 1.4gb for 32bit process or depends for 64bit process by your server memory, so you should never put a value higher than this one otherwise you will receive an exception during process.

The formula is something like this, call the cache cleaning when working set > 1.4gb for 32bit and all memory available in that time for 64bit or – registry threshold.

For the value I suggest you insert the value 1000(32bit) or around the 1800(64bit) in decimal: 

...the values will be used automatically and no need to restart any service because those settings are live.

Have a nice week laughing!

 

Best regards,

Luca

Close