Scanshare 5.22.1 installs with difficulty, then cannot access via browser

  • Last Post 28 February 2022
amir posted this 16 February 2022

I have the task of installing Scanshare on a remote server and mirroring Scanshare workflows from our local Scanshare server to the remote server.

System 1)

We have Scanshare v5.21.05 64bit installed locally (Windows 2016 on ESXi 6.5). On this server, When I try to access Scanshare, it doesn't go in. We have renewed our NFR licence key, but I cannot enter Scanshare, the log still says:

Error | Invalid license: Trial period of license is expired.

I cannot get into the Scanshare to change/re-apply the registration key/activation code/serial number. I cannot find it in registry to change it manually either.


System 2)

I installed Scanshare v5.21.12 64bit on a remote computer (Windows 10 Pro 21H2 Core i5-10400T, 16GB RAM, SSD), ran it the first time and managed to register it with supplied activation key/serial number/registration code. Restarted the remote computer and now it doesn't open. I restarted the computer several times. When I open https://localhost:60440 on Chrome or Firefox or Edge or IE, at first I get an error (Firefox:  SSL_ERROR_BAD_CERT_DOMAIN) or (Chrome: ERR_CONNECTION_REFUSED) and when I Accept the Risk and Continue, then nothing happens. Blank page, nothing to show. I then upgraded it to v5.22.01 64bit hoping it would fix the issue and during installation, I got an error that said:

An error occurred while removing IIS configuration: Filename: \\?\C:\WINDOWS\system32\inetsrv\config\applicationHost.config

Error: Cannot write configuration file

I read online that this happens when the computer has no space. This computer has 407 GB free on its SSD. Another suggested to delete the applicationHost.config and the installation would recreate it. When I moved it and ran the installed again, it complained this time with:

An error occurred while removing IIS configuration: Filename: \\?\C:\WINDOWS\system32\inetsrv\config\applicationHost.config

Error: Cannot read the configuration file

So I put it back and ran the installer the third time as Administrator and let it give me the first error (cannot write configuration file) and restarted the computer. Still the same. Does not show anything.

Any ideas?


Order By: Standard | Newest | Votes
luca.scarpati posted this 16 February 2022

 Hi Amir,


I try to answer your questions, but I remind you that this is a public forum and not the support portal.

So for this type of question and to avoid publishing sensitive data that may be in your attachment, I suggest you contact our support.

Here you go:

1. we never suggest to change settings and settings manually in your environment especially for the license because Scanshare notices the changes and invalidates the whole system.

If you want to update your license, try our commands via CMD ... but make sure your license has been updated, have you requested an extension?

2. in what sense does it not open? did you check that IIS was running and correct? that's strange issue from your screen. Did you change anything in the hosts file?


As mentioned at the beginning your questions are too specific, we suggest you write to our support.


Best regards,


amir posted this 17 February 2022

Hi Luca,

Thank you for your reply. I tried to unregister and re-register the serial number and I got various errors. In the end, I checked all computers at our office and found out that there was another machine with ScanShare v 5.21.03 with that serial number. So I unregistered the serial number and re-registered it and it worked. On that machine, I could login and all. So That's OK for that machine.


As for System 2 (remote machine), the problem remains. I will create a support ticket for that. Thank you for your help regarding command line commands, couldn't have done it without that.



luca.scarpati posted this 17 February 2022

Hi Amir,


you're welcome.

  1. Ok perfect -> it's standard and basic steps: never have the same serial on two machines, Scanshare notices and invalidates everything.
  2. Our support team will be happy to help you.


Have a nice day!


Best regards,


amir posted this 28 February 2022

I'll post a reply so everyone can see how it was fixed. The problem was with IIS. Once IIS was uninstalled, system restarted, IIS reinstalled, then ScanShare reinstalled, everything started to work again.

This was a new system and it only had one application installed: Scanshare. After a few days it stopped working. Not sure what happened in between.

Anyways if someone is having that issue, try to host a simple HTML file. If you cannot, then perform above tasks.