Cannot uninstall previous version

  • Last Post 03 December 2018
  • Topic Is Solved
Dimiter Sotirov posted this 30 November 2018

Hello all.

I am having trouble uninstalling a previous version. I need to address an issue with SharePoint folders which seems to have been resolved in v. This version would not upgrade the previous one (4.9.1) but requires the latter be uninstalled first. During the uninstallation process I get an "The system cannot find the file specified". The error message window is titled "Tablacus.ScriptControl".

I tried unistallting from Control Panel and from the installer - same thing.

Any help will be appreciated.



Order By: Standard | Newest | Votes
luigi.zurolo posted this 03 December 2018

Hi Dimiter,

yes correct, when using internal versions (only 4th version digit updated) you need to uninstall manually the existing one because Windows Installer is only using 3 digits of the version number, so is same version as being seen as generically 4.9.1.

About the error this is the 64bits scripting component, are you using 64bits versions? Can you please check if you have the file called "tsc.dll" inside the folder Web\App_Data\Dependecies of the installation folder?

If yes you can register this component manually from Windows CMD (as administrator) and launch again the uninstaller, the command to register is:

regsvr32 tsc.dll


Dimiter Sotirov posted this 03 December 2018

Luigi, thank you. That did it!

Much appreciated.


  • Liked by
  • luigi.zurolo